POV-Ray

The Persistence of Vision Raytracer (POV-Ray).

This is the legacy Bug Tracking System for the POV-Ray project. Bugs listed here are being migrated to our github issue tracker. Please refer to that for new reports or updates to existing ones on this system.

Tasklist

FS#94 - Unexpected refraction angle in interfaces with changing IOR <> 1.0

Attached to Project: POV-Ray
Opened by Kai Schwebke (kai) - Friday, 09 April 2010, 14:42 GMT
Last edited by Chris Cason (chrisc) - Friday, 31 December 2010, 14:39 GMT
Task Type Definite Bug
Category Backend → Texture/Material/Finish
Status Closed
Assigned To Christoph Lipka (clipka)
Operating System All
Severity High
Priority Normal
Reported Version 3.70 beta 36
Due in Version 3.70 beta 37
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

I’ve tried to model this setup:
http://kschwebke.webng.com/povray/ior-interfaces/drawing.png with the following SDL:
http://kschwebke.webng.com/povray/ior-interfaces/rs2.pov.txt

A small overlap between the two transparent solids is needed, because a gap
would lead to total reflection. The camera in the test scene looks in the
direction of the ray in the setup drawing. The setup is surrounded with angular
markers, so one can easily read the final resulting looking angle.

POV-Ray 3.6.1 renders the expected result (~53° in the center of the screen):
http://kschwebke.webng.com/povray/ior-interfaces/rs2-35.jpeg

POV-Ray 3.7.0b35a (compiled Unix source) renders a different
(and in my opinion wrong) angle (~67°), however – for the very same scene file:
http://kschwebke.webng.com/povray/ior-interfaces/rs2-37b35a.jpeg

I’ve started a discussion about this issue in povray.beta-test: http://news.povray.org/povray.beta-test/thread/%3Cweb.4bba4677730ab9f3e8c084b40%40news.povray.org%3E/

All linked documents are also attached.

This task depends upon

Closed by  Chris Cason (chrisc)
Friday, 31 December 2010, 14:39 GMT
Reason for closing:  Fixed
Comment by Christoph Lipka (clipka) - Monday, 12 April 2010, 16:40 GMT
  • Field changed: Status (Investigating → Requires testing)
  • Field changed: Due in Version (Undecided → 3.70 beta 37)
  • Field changed: Percent Complete (0% → 90%)

Should be mostly fixed with task #4938.

The behavior will still be wrong (and different to 3.6 behavior) when the two objects almost - but not quite - touch each other, with a gap of something around ca. 1e-5 units or smaller. I suspect that overlap in this order of magnitude may still cause unexpected behavior in certain circumstances, too.

Comment by Grimbert Jérôme (Le_Forgeron) - Monday, 09 August 2010, 07:25 GMT

Looks like fixed: rendering of original scene is now similar 3.6 when done with 3.7beta38 from source (on amd64)

To render on Ubuntu, I had to install the msttcorefonts package, and add a +L/usr/share/fonts/truetype/msttcorefonts in the command line
(as well as removing the hard coded path of the font in the original scene).

Comment by Grimbert Jérôme (Le_Forgeron) - Thursday, 30 December 2010, 10:24 GMT

Tested with beta 41.
Updating scene to add #version 3.7; at the start, render is still ok. Can be closed.

Loading...