POV-Ray

The Persistence of Vision Raytracer (POV-Ray).

This is the legacy Bug Tracking System for the POV-Ray project. Bugs listed here are being migrated to our github issue tracker. Please refer to that for new reports or updates to existing ones on this system.

Tasklist

FS#276 - SDL Access to Spline Derivatives

Attached to Project: POV-Ray
Opened by Benedikt Adelmann (badelmann) - Tuesday, 12 March 2013, 16:19 GMT
Last edited by Christoph Lipka (clipka) - Tuesday, 12 March 2013, 18:18 GMT
Task Type Feature Request
Category Backend → Parser/SDL
Status Closed
Assigned To No-one
Operating System All
Severity Medium
Priority Normal
Reported Version 3.70 RC7
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

I would like to suggest an additional feature regarding splines. POV-Ray’s spline objects (spline {}) are very useful to create animation paths as a function of time from reference points; however, in many cases you do not only need a position to place an object correctly, but also its velocity etc., e.g. if you are animating a car moving along a spline you do not only need to know where the car is at a given clock value but also in which direction it is going. If you want to rotate the wheels correctly you even need to know how this direction is currently changing.

In a nutshell, if you are using splines to create an animation path, you might not only need the spline value itself, but also the value of its first and second derivative. So I suggest adding an SDL capability to access these values like it is possible to access the spline value for a given parameter.

I do not think it would be too difficult to add a feature like this as far as the backend is concerned, since for computing a (cubic) spline you need the first and second derivatives anyway. (They are probably not being stored separately, but a polynomial is not that hard to differentiate.)

Indeed I do not know how an SDL language construct for it should look like (i.e. whether to use ' and ‘’ like in mathematics or a second spline function parameter).

This task depends upon

Closed by  Christoph Lipka (clipka)
Tuesday, 12 March 2013, 18:18 GMT
Reason for closing:  Duplicate report
Additional comments about closing:  duplicate of FS#248
Comment by Benedikt Adelmann (badelmann) - Tuesday, 12 March 2013, 16:23 GMT

Oh, I just see this is similar to #248.

Loading...