POV-Ray

The Persistence of Vision Raytracer (POV-Ray).

This is the legacy Bug Tracking System for the POV-Ray project. Bugs listed here are being migrated to our github issue tracker. Please refer to that for new reports or updates to existing ones on this system.

Tasklist

FS#270 - render abort-continue (+C) sometimes skips blocks

Attached to Project: POV-Ray
Opened by Christoph Lipka (clipka) - Friday, 01 February 2013, 12:43 GMT
Last edited by William F Pokorny (wfpokorny) - Friday, 28 October 2016, 14:39 GMT
Task Type Definite Bug
Category Frontend → Other
Status Closed
Assigned To Christoph Lipka (clipka)
Operating System All
Severity High
Priority Urgent
Reported Version 3.70 release
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

When aborting a render when there are unfinished blocks among finished ones, under certain conditions some of those blocks are skipped when continuing the render later.

This task depends upon

Closed by  William F Pokorny (wfpokorny)
Friday, 28 October 2016, 14:39 GMT
Reason for closing:  Fixed
Additional comments about closing:  Related discussion from Feb 2016:
http://news.povray.org/povray.bugreports /thread/%3C56b181dc@news.povray.org%3E/< br />
Potentially still a problem with 3.7.0 per Christoph comments, but fixed in 3.7.1 in that final output image file is OK. Mike Horvath was running 3.7.0.

Comment by Christoph Lipka (clipka) - Friday, 01 February 2013, 12:46 GMT
  • Field changed: Task Type (Possible Bug → Definite Bug)
  • Field changed: Status (Investigating → Requires testing)
  • Field changed: Due in Version (3.70 release → 3.70 RC7)
  • Field changed: Percent Complete (0% → 100%)

fixed with change #5771

Comment by Christoph Lipka (clipka) - Sunday, 10 November 2013, 13:48 GMT

According to recent discussions on news://news.povray.org/povray.beta-test, the problem still persists in some situations.

Comment by Christoph Lipka (clipka) - Sunday, 10 November 2013, 15:37 GMT

The remaining issues turned out to be entirely unrelated to the root cause eliminated with #5771.

What happens is that when a radiosity render is restarted, the pretrace for the missing blocks is done again; during the early stages of this pretrace, the "pixels" may be far larger than the render blocks, and may overpaint some already rendered blocks.

Change #6086 provides a hotfix that limits the problem to the render preview. The generated image files will be fine.

Loading...