POV-Ray

The Persistence of Vision Raytracer (POV-Ray).

This is the legacy Bug Tracking System for the POV-Ray project. Bugs listed here are being migrated to our github issue tracker. Please refer to that for new reports or updates to existing ones on this system.

Tasklist

FS#249 - UTF-8 files with BOM not accepted

Attached to Project: POV-Ray
Opened by Christoph Lipka (clipka) - Tuesday, 17 July 2012, 17:51 GMT
Last edited by Christoph Lipka (clipka) - Wednesday, 21 August 2013, 13:22 GMT
Task Type Definite Bug
Category Backend → Parser/SDL
Status Closed
Assigned To Christoph Lipka (clipka)
Operating System Windows 7
Severity Low
Priority Normal
Reported Version 3.70 RC6
Due in Version 3.70 RC7
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

POV-Ray fails to accept UTF-8 encoded files with a leading Byte Order Mark.

According to the code it was intended to recognize a leading BOM (or, more precisely, leading non-ASCII code sequences) and automatically switch to UTF-8, so this must be considered a bug rather than a missing feature.

This task depends upon

Closed by  Christoph Lipka (clipka)
Wednesday, 21 August 2013, 13:22 GMT
Reason for closing:  Fixed
Additional comments about closing:  No news for half a year now; presumably fixed for good.
Comment by Christoph Lipka (clipka) - Tuesday, 17 July 2012, 20:43 GMT

should be fixed with change #5699

Loading...