POV-Ray

The Persistence of Vision Raytracer (POV-Ray).

This is the legacy Bug Tracking System for the POV-Ray project. Bugs listed here are being migrated to our github issue tracker. Please refer to that for new reports or updates to existing ones on this system.

Tasklist

FS#224 - Keyword Completion does not work for several names

Attached to Project: POV-Ray
Opened by Dietmar Viertel (viertel) - Saturday, 22 October 2011, 17:41 GMT
Last edited by William F Pokorny (wfpokorny) - Tuesday, 29 November 2016, 12:26 GMT
Task Type Compatibility Issue
Category Frontend → Editor
Status Closed
Assigned To Chris Cason (chrisc)
Operating System Windows 7
Severity Low
Priority Normal
Reported Version 3.70 RC3
Due in Version 3.70 release
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Keyword Completion does not work for several names.
I miss it for animation related names like frame_number or final_frame.

Typing “fram{TAB}” just inserts a TAB character after “fram” instead of completing it to frame_number.

Independently of that bug, typing {TAB} repeatedly does not cycle through possible names:
“fr{TAB}” gives “frequency” and “fresnel” and that’s all.

In version 3.6 it worked well.

My system is Windows 7 64bit and PovRay is 3.7.0.RC3.msvc9.win64

This task depends upon

Closed by  William F Pokorny (wfpokorny)
Tuesday, 29 November 2016, 12:26 GMT
Reason for closing:  Fixed
Additional comments about closing:  Closing this issue out as mechanism to add arbitrary keywords in place. If particular keywords are today missing, please open new, specific to keyword completion, issue(s) on github.
Comment by Thorsten Fröhlich (thorsten) - Saturday, 22 October 2011, 17:55 GMT

This is not a bug. In POV-Ray 3.7 several keywords have been turned into defines. As such, they no longer appear as keywords.

Comment by Dietmar Viertel (viertel) - Sunday, 23 October 2011, 21:35 GMT

Thanks for your answer, Thorsten.
Do you know about the reason for this change? I think it's not only "just for fun".

But now I know that I have to accept that behaviour, which is by design.
And that this is another task for AutoHotkey to suppert my laziness :)

Comment by Chris Cason (chrisc) - Monday, 28 January 2013, 01:17 GMT

This should be mitigated in RC7, which allows arbitrary keywords to be added to the editor's syntax and keyword expansion.

Loading...