POV-Ray

The Persistence of Vision Raytracer (POV-Ray).

This is the legacy Bug Tracking System for the POV-Ray project. Bugs listed here are being migrated to our github issue tracker. Please refer to that for new reports or updates to existing ones on this system.

Tasklist

FS#198 - Missing closing brace in function definition causes memory access violation

Attached to Project: POV-Ray
Opened by Robert McGregor (rmcgregor) - Monday, 14 March 2011, 11:30 GMT
Last edited by Christoph Lipka (clipka) - Thursday, 21 June 2012, 22:55 GMT
Task Type Definite Bug
Category Backend → Parser/SDL
Status Closed
Assigned To Christoph Lipka (clipka)
Operating System All
Severity Medium
Priority Normal
Reported Version 3.70 RC3
Due in Version 3.70 RC4
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Given the following two statements, a missing closing brace in the function declaration fn should throw a parse exception; instead it causes a memory access violation when trying to use fn in the second delcaration:

#local fn = function { 
  pigment { image_map { png "MultiPassBlobs3.png" gamma 1 map_type 0 once }} 
#local clr = fn(0,0,0);
This task depends upon

Closed by  Christoph Lipka (clipka)
Thursday, 21 June 2012, 22:55 GMT
Reason for closing:  Fixed
Additional comments about closing:  no news, so I guess the fix was effective
Comment by Christoph Lipka (clipka) - Monday, 14 March 2011, 13:31 GMT
  • Field changed: Summary (Pigment function memory access violation → Missing closing brace in function definition causes memory access violation)
  • Field changed: Status (Unconfirmed → Investigating)
  • Field changed: Due in Version (Undecided → 3.70 RC4)
  • Field changed: Operating System (Windows 7 → All)
  • Field changed: Percent Complete (0% → 50%)
  • Task assigned to Christoph Lipka (clipka)

Memory access violation is caused by attempting to access a function currently being defined; this happens not only with pigment functions, but with functions in general.

Comment by Christoph Lipka (clipka) - Monday, 14 March 2011, 13:36 GMT
  • Field changed: Status (Investigating → Requires testing)
  • Field changed: Percent Complete (50% → 100%)

Should be fixed with change #5421.

Loading...