POV-Ray

The Persistence of Vision Raytracer (POV-Ray).

This is the legacy Bug Tracking System for the POV-Ray project. Bugs listed here are being migrated to our github issue tracker. Please refer to that for new reports or updates to existing ones on this system.

Tasklist

FS#194 - command line parse error

Attached to Project: POV-Ray
Opened by Jim Holsenback (jholsenback) - Monday, 21 February 2011, 17:39 GMT
Last edited by Jim Holsenback (jholsenback) - Sunday, 27 February 2011, 14:07 GMT
Task Type Definite Bug
Category Backend → Parser/SDL
Status Closed
Assigned To No-one
Operating System All
Severity Low
Priority Normal
Reported Version 3.70 RC3
Due in Version 3.70 RC4
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

povray +Imesh_camera.pov +Omesh_camera.png +FN +W800 +H600 produces a “Failed to parse command-line option” error. when I rename my pov source file to ess_mesh_camera.pov it runs fine. seems to be pointing to a clash with the +im option. i also had another file that renaming it got me going.

This task depends upon

Closed by  Jim Holsenback (jholsenback)
Sunday, 27 February 2011, 14:07 GMT
Reason for closing:  Fixed
Comment by Thorsten Fröhlich (thorsten) - Monday, 21 February 2011, 17:47 GMT

The problem is indeed with the addition of the IM option, which simply is not possible as it cannot be decided by the parser of command line options. We need a different option shortcut for IM functionaility.

Comment by Jim Holsenback (jholsenback) - Monday, 21 February 2011, 18:12 GMT

since the next expected character after +im is a number, perhaps the trap can be refined instead.

Comment by Christoph Lipka (clipka) - Monday, 21 February 2011, 18:20 GMT

no kludges please. "m20" is a valid filename, too.

Comment by Grimbert Jérôme (Le_Forgeron) - Monday, 21 February 2011, 18:25 GMT

Did anyone notice that a space can save a lot of thing.
povray +I mesh_camera.pov ... is ok

Comment by Christoph Lipka (clipka) - Monday, 21 February 2011, 18:29 GMT

it still breaks backward compatibility with e.g. existing shell scripts.

Comment by Thorsten Fröhlich (thorsten) - Monday, 21 February 2011, 18:41 GMT

Did anyone notice that a space can save a lot of thing.
povray +I mesh_camera.pov ... is ok

Yes, because it is an empty string +I option plus interpretation of the file name as input file (because it has a .pov extension).

Comment by Grimbert Jérôme (Le_Forgeron) - Monday, 21 February 2011, 19:00 GMT

What does IM stand for ?
Would +MI be ok ?
(from perforce, Max_Image_Buffer_Memory +IM... so +MI does still make sense)

In processrenderoptions.cpp, the M* section is empty enough (MBint, MB void, MVfloat), so an easy move could be +MI
(Max Image... instead of Image Memory !)
Or +MIM int ?


Comment by Grimbert Jérôme (Le_Forgeron) - Sunday, 27 February 2011, 13:23 GMT

Corrected with #5414, +MI is the new name of the option.

Comment by Jim Holsenback (jholsenback) - Sunday, 27 February 2011, 14:05 GMT

Thanks ... works both on cmd-line and ini option now

Loading...