POV-Ray

The Persistence of Vision Raytracer (POV-Ray).

This is the legacy Bug Tracking System for the POV-Ray project. Bugs listed here are being migrated to our github issue tracker. Please refer to that for new reports or updates to existing ones on this system.

Tasklist

FS#188 - no_reflection broken

Attached to Project: POV-Ray
Opened by Yoshinori Tagawa (y1tagawa) - Wednesday, 05 January 2011, 14:12 GMT
Last edited by Christoph Lipka (clipka) - Saturday, 26 February 2011, 00:35 GMT
Task Type Definite Bug
Category Backend → Texture/Material/Finish
Status Closed
Assigned To No-one
Operating System Windows XP
Severity High
Priority High
Reported Version 3.70 RC1
Due in Version 3.70 RC2
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

I rendered attached .pov file with both 3.62 and 3.7RC1, and got different output between them.
In 3.7RC1, it looks like no_reflection option of the black sphere doesn’t work.

This task depends upon

Closed by  Christoph Lipka (clipka)
Saturday, 26 February 2011, 00:35 GMT
Reason for closing:  Fixed
Comment by Christoph Lipka (clipka) - Wednesday, 05 January 2011, 17:58 GMT
  • Field changed: Summary (rendered image different between 3.62 and 3.7RC1 → no_reflection broken)
  • Field changed: Status (Unconfirmed → New)
  • Field changed: Category (Backend → Texture/Material/Finish)
  • Field changed: Severity (Medium → High)
  • Field changed: Priority (Normal → High)

From some toying around with the scene, it seems as if POV-Ray is forgetting that it’s tracing a reflected ray when the ray passes through a (semi-)transparent object.

Comment by Christoph Lipka (clipka) - Wednesday, 05 January 2011, 19:27 GMT
  • Field changed: Status (New → Requires testing)
  • Field changed: Due in Version (Undecided → 3.70 RC2)
  • Field changed: Percent Complete (0% → 100%)

should be fixed with change #5350.

Comment by Grimbert Jérôme (Le_Forgeron) - Wednesday, 09 February 2011, 19:19 GMT

Tested with 3.7RC3+ (up to #5402), rendered picture is now like the 3.6.2 one.

Loading...