POV-Ray

The Persistence of Vision Raytracer (POV-Ray).

This is the legacy Bug Tracking System for the POV-Ray project. Bugs listed here are being migrated to our github issue tracker. Please refer to that for new reports or updates to existing ones on this system.

Tasklist

FS#168 - noise_generator default broken

Attached to Project: POV-Ray
Opened by Christian Froeschlin (froesccn) - Tuesday, 19 October 2010, 15:28 GMT
Last edited by Chris Cason (chrisc) - Wednesday, 15 December 2010, 19:05 GMT
Task Type Definite Bug
Category Backend → Texture/Material/Finish
Status Closed
Assigned To Christoph Lipka (clipka)
Operating System All
Severity Medium
Priority Normal
Reported Version 3.70 beta 38
Due in Version 3.70 beta 40
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

[Original Title: “texture_map interpolation does not work correctly for some patterns”]

The below test scene should yield identical textures
T_STRAND1 and T_STRAND2 but this is not the case. Reported
and verified in

http://news.povray.org/povray.general/thread/%3C4cbd804b%241%40news.povray.org%3E/

The problem seems to affect bozo, bumps, dents, granite, spotted,
and maybe wrinkles. The problem was reported earlier in

http://news.povray.org/povray.beta-test/thread/%3C48112367%241%40news.povray.org%3E

with a comment that 3.6 gives the expected results

#declare C_STRAND = color rgb 1;

#declare C_CLEAR  = color rgb 0;

#declare T_STRAND = texture
{
  pigment {color C_STRAND}
}

#declare T_CLEAR = texture
{
  pigment {color C_CLEAR}
}

#declare T_STRANDS1 = texture
{
  pigment
  {
    granite scale 2 color_map
    {
      [0.0 color C_STRAND]
      [0.5 color C_CLEAR]
      [1.0 color C_CLEAR]
    }
  }
}

#declare T_STRANDS2 = texture
{
  granite scale 2 texture_map
  {
    [0.0 T_STRAND]
    [0.5 T_CLEAR]
    [1.0 T_CLEAR]
  }
}

plane
{
  z, 10
  texture {T_STRANDS1}
  //texture {T_STRANDS2}
} 
This task depends upon

Closed by  Chris Cason (chrisc)
Wednesday, 15 December 2010, 19:05 GMT
Reason for closing:  Fixed
Comment by Christoph Lipka (clipka) - Saturday, 30 October 2010, 14:44 GMT

The root cause seems to be a failure of POV-Ray to properly initialize noise_generator to its official default of 2 when using patterns directly inside a texture{} statement, leaving the value set to 0. This results in the code behaving as if noise_generator was set to 1.

Comment by Christoph Lipka (clipka) - Saturday, 30 October 2010, 15:24 GMT

Further analysis reveals that the global noise_generator setting does not have any effect at all in POV-Ray 3.7:

- texture_map patterns invariably default to noise_generator 0 (effectively the same as 1).
- pigment_map patterns invariably default to noise_generator 2.

POV-Ray 3.6 has none of these issues.

Comment by Christoph Lipka (clipka) - Monday, 01 November 2010, 17:56 GMT

fixed with change #5179

Comment by Grimbert Jérôme (Le_Forgeron) - Monday, 08 November 2010, 17:17 GMT

Confirmation that current perforce version (up to #5184) does make the issue goes away (so, #5179 is successful, as later # are not related).
For the record, it even seems that agate was also affected (it was very very subtle).

Loading...