POV-Ray

The Persistence of Vision Raytracer (POV-Ray).

This is the legacy Bug Tracking System for the POV-Ray project. Bugs listed here are being migrated to our github issue tracker. Please refer to that for new reports or updates to existing ones on this system.

Tasklist

FS#158 - Antialias Gamma reporting error

Attached to Project: POV-Ray
Opened by Jim Holsenback (jholsenback) - Tuesday, 20 July 2010, 23:36 GMT
Last edited by Jim Holsenback (jholsenback) - Sunday, 26 September 2010, 00:51 GMT
Task Type Definite Bug
Category Frontend → Other
Status Closed
Assigned To Christoph Lipka (clipka)
Operating System All
Severity Low
Priority Normal
Reported Version 3.70 beta 38
Due in Version 3.70 beta 39
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

value is erroneously clipped to the range 0..1 before being displayed

This task depends upon

Closed by  Jim Holsenback (jholsenback)
Sunday, 26 September 2010, 00:51 GMT
Reason for closing:  Fixed
Comment by Christoph Lipka (clipka) - Thursday, 22 July 2010, 10:58 GMT

fixed with change #5071

Comment by Jim Holsenback (jholsenback) - Thursday, 22 July 2010, 11:28 GMT

pulled and tested #5071 (works ok fine) ... danke

Comment by Jim Holsenback (jholsenback) - Sunday, 12 September 2010, 13:56 GMT

As a follow-up: was struggling with some AA issues with my current project. While trying to trouble-shoot the cause I noticed a behavior I can't explain. The reporting now works just fine (reports my command-line settings properly), however when I try to specify Antialias_Gamma=off it doesn't parse, but WILL pass the -AG option (no nag) while STILL reporting that it's on at my specified value. Was it intended to have AG on all the time, when any AA is used (at the default or user specified value) ... shouldn't I be able to turn this option off if I wish?

Comment by Christoph Lipka (clipka) - Wednesday, 15 September 2010, 16:28 GMT

"Neutral" behaviour can be achieved with Antialias_Gamma=1.0; I'm not sure why -AG doesn't give a warning. Maybe it should be changed so that Antialias_Gamma=0.0 (or =off, or -AG) is interpreted as Antialias_Gamma=1.0.

Comment by Grimbert Jérôme (Le_Forgeron) - Saturday, 25 September 2010, 19:32 GMT

Displayed value is now 2.5 for benchmark. Looks good.
(beta 39 from sources (via perforce))

I would like to suggest to close.

Loading...