POV-Ray

The Persistence of Vision Raytracer (POV-Ray).

This is the legacy Bug Tracking System for the POV-Ray project. Bugs listed here are being migrated to our github issue tracker. Please refer to that for new reports or updates to existing ones on this system.

Tasklist

FS#153 - Error determining I/O permissions when using .ini file

Attached to Project: POV-Ray
Opened by Joseph Berry (jberry02) - Wednesday, 30 June 2010, 03:43 GMT
Last edited by Chris Cason (chrisc) - Monday, 28 January 2013, 01:12 GMT
Task Type Possible Bug
Category Platform-specific → Runtime error
Status Closed
Assigned To Chris Cason (chrisc)
Operating System All
Severity Low
Priority Normal
Reported Version 3.70 beta 37a
Due in Version 3.70 release
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

clipka anonymous@anonymous.org wrote:
> Am 29.06.2010 04:27, schrieb jberry02:
>
> > First, note that this is the Windows version.
> > Second the issue is not with opening the ini file, but with opening the scene
> > file from within the ini file.
> >
> > I have a scene.ini file, that has a line:
> >
> > Input_File_Name=scene
> >
> > under POV-Ray 3.5 *and* POV-Ray 3.6, the scene defined in the file scene.pov is
> > rendered properly using the parameters specified in the scene.ini file. The ini
> > file is opened from the POV-Ray GUI, and run using the “Run” button.
> >
> > under POV-Ray 3.7, I get an error - I originally thought that it was simply not
> > looking for scene.pov (i.e., it wasn’t adding the .pov extension when trying to
> > open the scene file), but looking closer the error is *actually*:
> >
> > Input file ‘C:\[...]\scene’ not found; cannot determine I/O permission for
> > write.
> > Failed to start render: Cannot open file.
> >
> > In other words, it appears that the problem is that it isn’t adding the default
> > ..pov extension when it is trying to do the I/O permission check. I do not have
> > any special I/O permisssions configured for any version of POV-Ray (I get the
> > pop-up dialogs), and this is a change in behavior from 3.6 to the current beta
> > of 3.7. The scene.pov file is not in any of the POV-Ray directories - it is in
> > a separate tree where I keep my scene files.
>
> Having looked at it in a debugger, I can confirm that there is a
> problem, and that you don’t seem to be far off the mark:
>
> The error occurs when POV-Ray tries to determine the I/O permissions for
> the /output/ file. If that isn’t explicitly specified with a path,
> POV-Ray will try to get the path from the input file; however, it will
> take the unprocessed parameter (in the sample case “scene”) rather than
> the file name POV-Ray makes of it (”scene.pov”), and then attempts to
> get the full /long/ path name of the file (remember the good old 8.3
> filenames for compatibility with 16-bit programs?), which only works
> when the file exists.
>
> Would you mind submitting a bug report to <http://bugs.povray.org>?

This task depends upon

Closed by  Chris Cason (chrisc)
Monday, 28 January 2013, 01:12 GMT
Reason for closing:  Fixed
Additional comments about closing:  This is fixed in RC7.

Loading...