POV-Ray

The Persistence of Vision Raytracer (POV-Ray).

This is the legacy Bug Tracking System for the POV-Ray project. Bugs listed here are being migrated to our github issue tracker. Please refer to that for new reports or updates to existing ones on this system.

Tasklist

FS#150 - Windows file association problems (Win7 only??)

Attached to Project: POV-Ray
Opened by Mike H (SharkD) - Friday, 25 June 2010, 13:52 GMT
Last edited by William F Pokorny (wfpokorny) - Thursday, 19 January 2017, 15:24 GMT
Task Type Compatibility Issue
Category Frontend
Status Closed
Assigned To Chris Cason (chrisc)
Operating System Windows 7
Severity Low
Priority Normal
Reported Version 3.70 beta 37a
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Windows allows you to associate programs with file extensions using the “Open with” file manager right-click menu extension.

I’m running Windows 7 64bit, and installed the 64 bit versions of 3.6.2 and the beta appropriately.

A couple of problems that I haven’t tested very thoroughly:

1. If you have both POV 3.6.2 and the beta installed at the same time, you can no longer using this dialog change the association to the beta once it has been created for 3.6.2. There’s no error or anything; it just opens the file inside 3.6.2 instead. Maybe because both versions appear as “POV-Ray for Windows” to this dialog? Would adding the version number to the name fix things? Anything I can do on my end of things to resolve this?

2. In POV-Ray 3.6.2, I can use this dialog to open *.inc, *.txt and other files in POV-Ray, but only if POV-Ray isn’t already running. If POV-Ray is already running I get an “Only /EDIT and /RENDER may be passed to previous instance” error. Files with the *.pov extension open properly regardless, without any error. I am unable to test this in the beta at the moment due to the first problem unfortunately. Could someone please test this with the beta and confirm whether the behavior also exists?

3. With the POV-Ray 3.7 beta, entering the following command in the command prompt results in the same error:

   "C:\Program Files\POV-Ray for Windows v3.7\bin\pvengine64.exe" "D:\Working\Povray\GearHead\LoadingScreen\btr_maanji.pov"

If I change it to the following it works however:

   "C:\Program Files\POV-Ray for Windows v3.7\bin\pvengine64.exe" /EDIT "D:\Working\Povray\GearHead\LoadingScreen\btr_maanji.pov"

Is this error/behavior really necessary? Would it be OK to instead change the behavior when the /EDIT flag is omitted in the
command-line such that the file is opened in the editor by default, without throwing an error?

This task depends upon

Closed by  William F Pokorny (wfpokorny)
Thursday, 19 January 2017, 15:24 GMT
Reason for closing:  Fixed
Additional comments about closing:  Closing as fixed given the time since the last update indicating everything fixed. As a linux user I'm not able to test. Please open a new issue on github if anything related to this is still amiss.
Comment by Mike H (SharkD) - Friday, 25 June 2010, 13:53 GMT

Side note: How do I edit tasks after I've submitted them? I introduced a slight formatting error that I'd like to fix. I'm able to edit comments, but not the original task entries.

Comment by Mike H (SharkD) - Friday, 25 June 2010, 15:22 GMT

With the POV-Ray beta in a non-running state, I executed

"C:\Program Files\POV-Ray for Windows v3.7\bin\pvengine64.exe" "D:\Working\Povray\GearHead\LoadingScreen\btr_maanji.pov"

from the command prompt, and it immediately rendered the file, but did not open the file in the editor window.

Comment by Thorsten Fröhlich (thorsten) - Tuesday, 23 August 2011, 05:54 GMT

Has this changed recently?

Comment by Chris Cason (chrisc) - Tuesday, 04 September 2012, 21:42 GMT

Tested with RC6, a variation of the first example (two quoted paths, tried with and without spaces embedded) works as expected (i.e. it renders the file).

Comment by Chris Cason (chrisc) - Monday, 28 January 2013, 01:11 GMT
  • Field changed: Task Type (Possible Bug → Compatibility Issue)
  • Field changed: Status (Unconfirmed → Requires testing)
  • Field changed: Due in Version (Undecided → 3.70 release)
  • Field changed: Percent Complete (0% → 90%)
  • Task assigned to Chris Cason (chrisc)

The issue where files are associated with POV by the shell and then not being opened in the editor should be mostly mitigated as of RC7. I’ve also changed the name embedded in the EXE’s version resource to include the version as a string; this appears the only generic way to ensure that Windows shows a distinctive name when showing the ‘open with’ menu. Unfortunately short of fixing the registry directly each time it detects a new file association, there’s no way for POV to force Windows to be more intelligent about what it displays in this menu for cases where a user associates an extension manually.

Comment by Christoph Lipka (clipka) - Friday, 19 July 2013, 06:23 GMT
  • Field changed: Status (Requires testing → Released for community testing)
  • Field changed: Due in Version (3.70 RC7 → Undecided)

fixed with change #5755

Loading...