POV-Ray

The Persistence of Vision Raytracer (POV-Ray).

This is the legacy Bug Tracking System for the POV-Ray project. Bugs listed here are being migrated to our github issue tracker. Please refer to that for new reports or updates to existing ones on this system.

Tasklist

FS#109 - Debug_File No Longer Appends Frame by Frame Debug Data

Attached to Project: POV-Ray
Opened by David Snell (fillibar) - Friday, 07 May 2010, 01:10 GMT
Last edited by William F Pokorny (wfpokorny) - Monday, 28 November 2016, 12:56 GMT
Task Type Compatibility Issue
Category Backend → Other
Status Closed
Assigned To Chris Cason (chrisc)
Operating System All
Severity Very Low
Priority Low
Reported Version 3.70 beta 37a
Due in Version Future release
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

The function of the “Debug_File=” .ini option has changed from 3.6 to 3.7.37a.
In 3.6, when rendering multiple frames, a debug file would be created that then appended the debug lines for each frame into the file. It was therefore able to have debug data that identified what parameters were used in which frame in case a frame did not have the desired effect.

In 3.7.37a, the debug file does not perform this function. Instead it creates a new debug file (overwriting the prior) with each new frame. Therefore the debug data is only useful for the final frame (or wherever the render was halted). This is useful for a single frame render or for identifying a fault within a series of frames (because only the last one will remain) but it is not useful for many frames that render successfully.

This problem does not cause any rendering errors or other defects. The debug file specified will only contain the debug data for the last frame rendered.

Per discussion in the forum it was unknown if this was a bug or “feature”. At this time it is causing me a problem so I am submitting the bug. No related bugs were found searching for “output” or “debug” in any status.

Operating System in use is Windows XP. I cannot test 3.7.37a in additional OSes, but it does not seem like it would be OS-specific.

This task depends upon

Closed by  William F Pokorny (wfpokorny)
Monday, 28 November 2016, 12:56 GMT
Reason for closing:  Fixed
Additional comments about closing:  Tested and confirmed fixed in 3.7.0 onward.
Comment by David Snell (fillibar) - Wednesday, 09 June 2010, 01:41 GMT

I have since obtained access to Windows 7 Ultimate and Home Premium (not that there is any difference for POV-Ray) and this problem exists in both.

Comment by Thorsten Fröhlich (thorsten) - Friday, 02 July 2010, 05:14 GMT

The change that lets POV-Ray overwrite all output files is intentional. I am not sure which behavior is better though.

Comment by Chris Cason (chrisc) - Monday, 28 January 2013, 00:56 GMT

This is fixed in 3.7 RC7.

Loading...